For a long time that I’v wanted to install logstalgia….
Todays is the day!

So, we need to download Xcode 5.1.1 (Mountain Lion) from https://developer.apple.com/downloads/.

ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"
brew install wget
wget https://github.com/acaudwell/Logstalgia/releases/download/logstalgia-1.0.6/logstalgia-1.0.6.tar.gz
tar -zxvf logstalgia*.gz
cd logstalgia*

brew install pkg-config glew sdl2 SDL2_image sdl SDL_image boost GLM freetype pcre
make install

This should do the work.


Other way to install is using MacPorts – logstalgia @ macports -.

Via terminal

sudo port -p -u install "nolstalgia"

Using GUI?
You can try jportsui Java based, graphical user interface to MacPorts 2.0+.


If you have an old GCC verion (prior to 4.6) you might get the following errors…

Unfortunately while making “make” I had an error f*ck!

cc1plus: error: unrecognized command line option "-Wno-unused-but-set-variable"
cc1plus: error: unrecognized command line option "-std=gnu++0x"
make: *** [src/logstalgia-ncsa.o] Error 1

According to some pages GCC is to old. We need GCC 4.6, mine is 4.2.1.

gcc version 4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2336.11.00)


Sources / Related links


Leave a Reply

Your email address will not be published. Required fields are marked *